This project has moved. For the latest updates, please go here.

QR Code V7

Jan 14, 2014 at 12:00 PM
I was using an older version of the ZXing.net, and i mentionned the version (7) to the QRCodeWriter class. i was using an hashtable like
oHints.Add("Version", "7");
With the last version , it seems things are little bit different. My hashtable became a Dictionary<ZXing.EncodeHintType, object>. So there is no version in ZXing.EncodeHintType and the QRcode seems to be different.

Is there a way to add version to QRCodeWriter ?
Coordinator
Jan 14, 2014 at 8:02 PM
I'm a little bit confused. ZXing.Net and QRCodeWriter class never ever supported an encoding hint with the name "Version".
Are you sure that you use ZXing.Net before? What version was it?
Jan 15, 2014 at 8:26 AM
Thanks for the Answer. It seems than the old "zxing.dll" isn't a ZXing.net assembly, the version is 1.0.4818.20216 without description.
Now i am confused too, I'm really sorry for the mistake.

So ZXing.net looks pretty good, is it possible to encode QR-Code in specified version. In Documentation i've seen a ZXing.QrCode.Internal.Version.getVersionForNumber(int), so i didn't undestung how to use it.
Coordinator
Jan 15, 2014 at 8:29 PM
There is no option (at the moment) to set an explicit version which should be used.
It would be really interesting how this was implemented in "your version" of zxing.dll.
Have you a copy of the old dll which you can send me?